Discussion:
Tabbreite
(zu alt für eine Antwort)
Wolfgang Hopf
2019-06-20 12:20:52 UTC
Permalink
Hallo, ich wende mich jetzt mal wieder an die Fachleute hier.
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Auch die Eingabe browser.tabs.tabMinWidth in about:config bringt keine
Änderung weil sie nicht reagiert. Kann ich, und wenn ja wie, FF 67 dazu
überreden, tab_mix_plus-0.5.6.0-fx.xpi doch noch zu installieren.
Das wäre mir wichtig. Mit Tab Mix-Links komme ich nicht klar.

Danke für Tipps

wo
Manuel Reimer
2019-06-20 12:29:51 UTC
Permalink
Post by Wolfgang Hopf
Kann ich, und wenn ja wie, FF 67 dazu
überreden, tab_mix_plus-0.5.6.0-fx.xpi doch noch zu installieren.
Wenn das die Frage ist, dann ist die Antwort einfach.

Nein.

Selbst wenn man sehr viel Verrenkungen anstellen würde: Viele der
Schnittstellen, die alte Addons genutzt haben, sind lange inkompatibel
geändert oder gar gelöscht.

Gruß

Manuel
Ralf Zilian
2019-06-20 14:04:59 UTC
Permalink
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Auch die Eingabe browser.tabs.tabMinWidth in about:config bringt keine
Änderung weil sie nicht reagiert.
Was heißt "weil sie nicht reagiert"? Auf welchen Wert änderst Du die Pref?
Post by Wolfgang Hopf
Kann ich, und wenn ja wie, FF 67 dazu
überreden, tab_mix_plus-0.5.6.0-fx.xpi doch noch zu installieren.
Das wäre mir wichtig. Mit Tab Mix-Links komme ich nicht klar.
Nein, die Erweiterung funktioniert nicht mehr im 67'er Fx.

und wech
Ralf
--
ERROR: Coffeepot not found - Operator halted.
Winfried Sonntag
2019-06-20 15:07:16 UTC
Permalink
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?

Servus
Winfried
--
WSUS Package Publisher:
https://github.com/DCourtel/Wsus_Package_Publisher
HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
GPO's: http://www.gruppenrichtlinien.de
NNTP-Bridge für MS-Foren:
https://github.com/JochenKalmbach/communitybridge
GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/
Wolfgang Hopf
2019-06-20 15:42:49 UTC
Permalink
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Die Tabs sind mir zu breit. Ich will sie schmaler haben. Und wie gesagt,
about:config und "browser.tabs.tabMinWidth" Eintrag ändert nichts.

wo
Ralf Zilian
2019-06-20 15:56:03 UTC
Permalink
Post by Wolfgang Hopf
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Die Tabs sind mir zu breit. Ich will sie schmaler haben. Und wie gesagt,
about:config und "browser.tabs.tabMinWidth" Eintrag ändert nichts.
Die Pref wirkt erst dann, wenn die Tabbar mit Tabs gefüllt ist und die
Tabbar überläuft.

und wech
Ralf
--
ERROR: Coffeepot not found - Operator halted.
Winfried Sonntag
2019-06-20 17:34:39 UTC
Permalink
Post by Wolfgang Hopf
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Die Tabs sind mir zu breit. Ich will sie schmaler haben. Und wie gesagt,
about:config und "browser.tabs.tabMinWidth" Eintrag ändert nichts.
Probier doch mal den Tipp aus diesem Artikel:
https://technikblog.gerhard-kerner.at/index.php?/archives/70-Firefox-23-Breite-der-Tabs-veraendern.html
browser.tabs.tabMaxWidth (maximale Breite, Standardwert: 250)

• Wichtiger Hinweis:
Existieren die oben beschriebenen Schlüssel unter "about:config" nicht
oder nicht mehr, kann die Breite der Tabs auch über die userChrome.css
definiert werden.

Servus
Winfried
--
WSUS Package Publisher:
https://github.com/DCourtel/Wsus_Package_Publisher
HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
GPO's: http://www.gruppenrichtlinien.de
NNTP-Bridge für MS-Foren:
https://github.com/JochenKalmbach/communitybridge
GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/
Manfred Hamernik
2019-06-20 17:48:14 UTC
Permalink
Post by Wolfgang Hopf
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Die Tabs sind mir zu breit. Ich will sie schmaler haben. Und wie gesagt,
about:config und "browser.tabs.tabMinWidth" Eintrag ändert nichts.
Gerade mit einem jungfräulichem Profil getestet und funktioniert bei
mir. Du kopierst dir den Text unten in die datei userChrome.css. Diese
befindet sich im Ordner chrome in deinem FF Profil. Falls es keinen
Ordner chrome gibt erstellst du ihn dir. So verhält es sich auch mit der
userChrome.css
Die Breite der Tabs kannst du dir individuell einstellen indem du die 3
Werte unten auf eine für dich akzepteble Zahl einstellst. Das ganze bei
geschlossenem FF und/oder einem Neustart danach.

Browsertabs auf fixe Breite einstellen:

.tabbrowser-tab:not([pinned="true"]) {
-moz-box-flex: 0!important;
width: 120px!important;
}

:root {
--tab_min_width: 120px;
--tab_max_width: 120px;
}
/*
.tabbrowser-tab:not([pinned]) {
min-width: var(--tab_min_width) !important;
clip-width: var(--tab_min_width) !important;
}

*/

#tabbrowser-tabs:not([overflow="true"])
.tabbrowser-tab[fadein]:not([pinned]) {
max-width: var(--tab_max_width) !important;
overflow: hidden !important;
}


Gruß, Manfred
--
Es ist nicht so schlimm wie's noch wird.
Wolfgang Hopf
2019-06-20 21:05:58 UTC
Permalink
Post by Manfred Hamernik
Falls es keinen
Ordner chrome gibt erstellst du ihn dir. So verhält es sich auch mit der
userChrome.css
Die Breite der Tabs kannst du dir individuell einstellen indem du die 3
Werte unten auf eine für dich akzepteble Zahl einstellst. Das ganze bei
geschlossenem FF und/oder einem Neustart danach.
.tabbrowser-tab:not([pinned="true"]) {
-moz-box-flex: 0!important;
width: 120px!important;
}
:root {
--tab_min_width: 120px;
--tab_max_width: 120px;
}
/*
.tabbrowser-tab:not([pinned]) {
min-width: var(--tab_min_width) !important;
clip-width: var(--tab_min_width) !important;
}
*/
#tabbrowser-tabs:not([overflow="true"])
.tabbrowser-tab[fadein]:not([pinned]) {
max-width: var(--tab_max_width) !important;
overflow: hidden !important;
}
So klappts.
Danke

wo
Arno Welzel
2019-06-20 18:40:05 UTC
Permalink
Post by Wolfgang Hopf
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Die Tabs sind mir zu breit. Ich will sie schmaler haben. Und wie gesagt,
about:config und "browser.tabs.tabMinWidth" Eintrag ändert nichts.
Ja - weil der nicht die *maximale* Breite festlegt, sondern die
*minimale*. Deshalb werden sie nicht schmaler, sondern nur *breiter*,
wenn man hier etwas über 76 eingibt. Aber schmaler als 76 wird eben
ignoriert.
--
Arno Welzel
https://arnowelzel.de
Michael Spohn
2019-06-22 19:53:36 UTC
Permalink
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Wo wir gerade bei TMP sind: Ich vermisse, dass ich die Anzahl der TABs
einstellen kann, wenn ich mit dem Mausrad in der TAB-Leiste scrolle.

Mit jedem Scroll möchte ich, dass _einen_ TAB weitergescrollt wird.

Kann man das irgendwie erreichen?

Alles andere von TMP vermisse ich schon gar nicht mehr.
--
Gruß
Michael
Winfried Sonntag
2019-06-22 21:14:58 UTC
Permalink
Post by Michael Spohn
Post by Winfried Sonntag
Post by Wolfgang Hopf
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Welche Funktionen vermisst Du denn? Was muss unbedingt funktionieren?
Wo wir gerade bei TMP sind: Ich vermisse, dass ich die Anzahl der TABs
einstellen kann, wenn ich mit dem Mausrad in der TAB-Leiste scrolle.
Mit jedem Scroll möchte ich, dass _einen_ TAB weitergescrollt wird.
Schau dir dieses Script an, evtl. tut es was Du möchtest.
https://www.camp-firefox.de/forum/thema/121503-mit-dem-mausrad-durch-tabs-scrollen/

Servus
Winfried
--
WSUS Package Publisher:
https://github.com/DCourtel/Wsus_Package_Publisher
HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
GPO's: http://www.gruppenrichtlinien.de
NNTP-Bridge für MS-Foren:
https://github.com/JochenKalmbach/communitybridge
GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/
Michael Spohn
2019-06-25 19:19:38 UTC
Permalink
Post by Winfried Sonntag
Post by Michael Spohn
Mit jedem Scroll möchte ich, dass _einen_ TAB weitergescrollt wird.
Schau dir dieses Script an, evtl. tut es was Du möchtest.
https://www.camp-firefox.de/forum/thema/121503-mit-dem-mausrad-durch-tabs-scrollen/
Sollte eigentlich das tun, was ich möchte, tut es aber nicht. Muss mal
abwarten, bis ich etwas Zeit habe, das Ganze noch mal genau
durchzulesen. Offensichtlich fehlt da noch etwas. :-)

Danke auf jeden Fall für den Tip! Sieht wirklich ganz brauchbar aus.
Arno Welzel
2019-06-20 18:37:45 UTC
Permalink
Post by Wolfgang Hopf
Kann ich, und wenn ja wie, FF 67 dazu
überreden, tab_mix_plus-0.5.6.0-fx.xpi doch noch zu installieren.
Nein, da Tab-Mix-Plus eine Schnittstelle in Firefox braucht, die es bei
Firefox 67 nicht mehr gibt.
--
Arno Welzel
https://arnowelzel.de
Erika Sammer
2019-06-21 07:38:42 UTC
Permalink
Post by Wolfgang Hopf
Hallo, ich wende mich jetzt mal wieder an die Fachleute hier.
Seit die meisten meine Addons nicht mehr laufen habe ich
gleich auf Firefox 67 gewechselt. Allerdings läuft da auch
mein geliebtes TabMixPlus wie auch einige andere Addons nicht.
Auch die Eingabe browser.tabs.tabMinWidth in about:config bringt keine
Änderung weil sie nicht reagiert. Kann ich, und wenn ja wie, FF 67 dazu
überreden, tab_mix_plus-0.5.6.0-fx.xpi doch noch zu installieren.
Das wäre mir wichtig. Mit Tab Mix-Links komme ich nicht klar.
Danke für Tipps
wo
Wenn Dich Modifikationen mit Hilfe der userchrome.css und der
usercontent.css interessieren, dann schau dir doch mal die Seite

https://github.com/Aris-t2/CustomCSSforFx/releases

an. Die Dateien kann man nach eigenen Wünschen modifizieren und
sich somit wieder dem alten Erscheinungsbild annähern.
--
Gruß
Erika
Wolfgang Hopf
2019-06-21 09:48:24 UTC
Permalink
Post by Erika Sammer
Wenn Dich Modifikationen mit Hilfe der userchrome.css und der
usercontent.css interessieren, dann schau dir doch mal die Seite
https://github.com/Aris-t2/CustomCSSforFx/releases
an. Die Dateien kann man nach eigenen Wünschen modifizieren und
sich somit wieder dem alten Erscheinungsbild annähern.
Ja, wenn nicht mein Englisch im Weg stünde. Ich weiß gar nicht was wohin
ich kopieren muss. In die userchrome.css oder in die prefs.js.

wo
Erika Sammer
2019-06-21 10:37:18 UTC
Permalink
Post by Wolfgang Hopf
Post by Erika Sammer
Wenn Dich Modifikationen mit Hilfe der userchrome.css und der
usercontent.css interessieren, dann schau dir doch mal die Seite
https://github.com/Aris-t2/CustomCSSforFx/releases
an. Die Dateien kann man nach eigenen Wünschen modifizieren und
sich somit wieder dem alten Erscheinungsbild annähern.
Ja, wenn nicht mein Englisch im Weg stünde. Ich weiß gar nicht was wohin
ich kopieren muss. In die userchrome.css oder in die prefs.js.
wo
Die .zip-Datei herunterladen und entpacken. Das Ergebnis sind 2
Dateien (userchrome.css und usercontent.css) und 3 kleine
Verzeichnisse. Diese 5 Kompnenten kopierst du in den Ordner
"chrome" innerhalb deines Firefox-Profils.

Wenn du magst kannst du die beiden .css-Dateinen auch edititieren
und nach deinem Geschmack anpassen.

Wenn es dir nicht gefällt, dann kannst du einfach alles wieder aus
deinem Profil löschen.
--
Gruß
Erika
Wolfgang Hopf
2019-06-21 12:18:34 UTC
Permalink
Post by Erika Sammer
Post by Erika Sammer
Wenn Dich Modifikationen mit Hilfe der userchrome.css und der
usercontent.css interessieren, dann schau dir doch mal die Seite
https://github.com/Aris-t2/CustomCSSforFx/releases an.
Wenn du magst kannst du die beiden .css-Dateinen auch edititieren
und nach deinem Geschmack anpassen.
Wenn es dir nicht gefällt, dann kannst du einfach alles wieder aus
deinem Profil löschen.
Das ist sehr passend für meine Bedürfnisse. Einzig den Inhalt meiner
userchrome.css habe ich wegen der Tabbreite noch eingefügt. Passt!

wo und danke Erika
Winfried Sonntag
2019-06-21 18:23:51 UTC
Permalink
Post by Wolfgang Hopf
Ja, wenn nicht mein Englisch im Weg stünde. Ich weiß gar nicht was wohin
ich kopieren muss. In die userchrome.css oder in die prefs.js.
deepl.com kann man gut für Übersetzungen nutzen.

Servus
Winfried
--
WSUS Package Publisher:
https://github.com/DCourtel/Wsus_Package_Publisher
HowTos zum WSUS Package Publisher http://www.wsus.de/wpp
GPO's: http://www.gruppenrichtlinien.de
NNTP-Bridge für MS-Foren:
https://github.com/JochenKalmbach/communitybridge
GP-PACK - PRIVACY AND TELEMETRIE: http://www.gp-pack.com/
Arno Welzel
2019-06-24 18:53:16 UTC
Permalink
Post by Wolfgang Hopf
Post by Erika Sammer
Wenn Dich Modifikationen mit Hilfe der userchrome.css und der
usercontent.css interessieren, dann schau dir doch mal die Seite
https://github.com/Aris-t2/CustomCSSforFx/releases
an. Die Dateien kann man nach eigenen Wünschen modifizieren und
sich somit wieder dem alten Erscheinungsbild annähern.
Ja, wenn nicht mein Englisch im Weg stünde. Ich weiß gar nicht was wohin
ich kopieren muss. In die userchrome.css oder in die prefs.js.
<https://translate.googleusercontent.com/translate_c?depth=1&rurl=translate.google.com&sl=auto&sp=nmt4&tl=de&u=https://github.com/Aris-t2/CustomCSSforFx/releases&xid=17259,1500004,15700021,15700186,15700191,15700256,15700259&usg=ALkJrhj5J8bnZmwdpbcYv2Y82gUTde47Hg>
--
Arno Welzel
https://arnowelzel.de
Loading...