Discussion:
Icon für HTM & HTML Dateien
(zu alt für eine Antwort)
Andreas Weller
2006-03-02 18:08:45 UTC
Permalink
Hallo,

ich verzweifle gerade an meiner Mozilla-Firefox Installation unter
Windows: Ich habe ein Problem mit meinen der im Windows Explorer
zugeordneten Icons. Der Explorer zeigt mir für eine HTML-Datei das
Symbol für "Unbekannter Dateityp" an, klicke ich drauf, öffnet sich
Firefox normal. Also kann's ja nur an den Icons liegen, dachte ich.
Schön: Gucke ich unter Windows Explorer, Ordneroptionen, zugeordnete
Dateitypen:

Wenn ich auf den Dateityp klicke um ihn zu bearbeiten, sehe ich für den
Dateityp (Erweiterung HTML oder HTM) das Symbol des Firefox-Browsers,
das ich auch gerne im Explorer angezeigt bekommen hätte, im Explorer
jedoch wird mir das Dateisymbol für unbekannte Dateien angezeigt, ganz
egal welches Icon ich auswähle.

Welche Zuordnung ist hier verloren gegangen? Ich möchte die Erweiterung
nicht unbedingt löschen, Da mit die ganzen Aktionen (Edit, Print, Open)
kaputt gehen.

Was ich schon ausprobiert habe: Im Regedit den IconHandler auf Firefox
umzubiegen, in dem Schlüssel ShellEx. Dort steht bei mir
"C:\..bla...\Firefox.exe,1" - also das zweite Icon mit dem Fuchs und dem
weissen Papier im Hinterfrund. Den IconCache von Windows habe ich auch
schon erhöht.

Was ist bei mir falsch? Weiss jemand genau, welche Einstellungen richtig
sind?

Ich verwende Mozilla Firefox 1.5.0.1, Windoof XP Home (5.1, Build 2600)
mit aktuellen Patches (SP2...), der eingebaute Internet Explorer ist
6.0.2900.2180

Vielen Dank für Eure Hilfe!

Grüße
Andreas
Siegfried Schmid
2006-03-02 22:01:42 UTC
Permalink
Post by Andreas Weller
Der Explorer zeigt mir für eine HTML-Datei das
Symbol für "Unbekannter Dateityp" an, klicke ich drauf, öffnet sich
Firefox normal. Also kann's ja nur an den Icons liegen, dachte ich.
Schön: Gucke ich unter Windows Explorer, Ordneroptionen, zugeordnete
Wenn ich auf den Dateityp klicke um ihn zu bearbeiten, sehe ich für den
Dateityp (Erweiterung HTML oder HTM) das Symbol des Firefox-Browsers,
das ich auch gerne im Explorer angezeigt bekommen hätte, im Explorer
jedoch wird mir das Dateisymbol für unbekannte Dateien angezeigt, ganz
egal welches Icon ich auswähle.
Hast du hier schon mal nachgesehen?
Extras -- Ordneroptionen -- Dateitypen -- Erweitert -- Anderes Symbol
--
sigi
Andreas Weller
2006-03-03 12:18:50 UTC
Permalink
Post by Siegfried Schmid
Post by Andreas Weller
Der Explorer zeigt mir für eine HTML-Datei das
Symbol für "Unbekannter Dateityp" an, klicke ich drauf, öffnet sich
Firefox normal. Also kann's ja nur an den Icons liegen, dachte ich.
Schön: Gucke ich unter Windows Explorer, Ordneroptionen, zugeordnete
Wenn ich auf den Dateityp klicke um ihn zu bearbeiten, sehe ich für den
Dateityp (Erweiterung HTML oder HTM) das Symbol des Firefox-Browsers,
das ich auch gerne im Explorer angezeigt bekommen hätte, im Explorer
jedoch wird mir das Dateisymbol für unbekannte Dateien angezeigt, ganz
egal welches Icon ich auswähle.
Hast du hier schon mal nachgesehen?
Extras -- Ordneroptionen -- Dateitypen -- Erweitert -- Anderes Symbol
Das hatte ich eigentlich oben beschrieben! Daran liegt es ja. HIER ist
das Icon vom Fox ja da, aber im Explorer nicht!
Ralf Eichler
2006-03-02 22:16:39 UTC
Permalink
Post by Andreas Weller
Hallo,
ich verzweifle gerade an meiner Mozilla-Firefox Installation unter
Windows: Ich habe ein Problem mit meinen der im Windows Explorer
zugeordneten Icons. Der Explorer zeigt mir für eine HTML-Datei das
Symbol für "Unbekannter Dateityp" an, klicke ich drauf, öffnet sich
Firefox normal. Also kann's ja nur an den Icons liegen, dachte ich.
Schön: Gucke ich unter Windows Explorer, Ordneroptionen, zugeordnete
Der Weg ist andersrum: du musst festlegen welches Programm diesen
Dateityp öffnen soll, und _daher_ kommt dann auch das Icon:

Rechte Maustaste auf die Datei, "Öffnen mit" anwählen. In der dann
aufpoppenden Liste Firefox auswählen und einen Haken machen bei "immer
mit diesem Programm öffnen.

Dann sollte sowohl das Öffnen gehen als auch die Dateien wieder das
richtige Icon haben.

R/\LF
Johannes Kastl
2006-03-03 12:34:22 UTC
Permalink
Post by Ralf Eichler
Dann sollte sowohl das Öffnen gehen als auch die Dateien wieder das
richtige Icon haben.
Ich kenne das Problem des OP obwohl ich deinen Weg gegangen bin. Bei
mir war statt unbekannt aber das IE-Icon. Noch schlimmer.

OJ
--
Eulenpost hat den Vorteil, daß man die Adresse des Empfängers nicht
kennen muß. Egal wo Sirius steckt, Hedwig bounct nicht. Und ein
nennenswertes SPAM-Problem scheint es auch nicht zu geben.
(Hans-Georg Bickel in de.alt.fan.harry-potter, 04.04.2003)
Andreas Weller
2006-03-03 12:39:51 UTC
Permalink
Post by Ralf Eichler
Post by Andreas Weller
Hallo,
ich verzweifle gerade an meiner Mozilla-Firefox Installation unter
Windows: Ich habe ein Problem mit meinen der im Windows Explorer
zugeordneten Icons. Der Explorer zeigt mir für eine HTML-Datei das
Symbol für "Unbekannter Dateityp" an, klicke ich drauf, öffnet sich
Firefox normal. Also kann's ja nur an den Icons liegen, dachte ich.
Schön: Gucke ich unter Windows Explorer, Ordneroptionen, zugeordnete
Der Weg ist andersrum: du musst festlegen welches Programm diesen
Rechte Maustaste auf die Datei, "Öffnen mit" anwählen. In der dann
aufpoppenden Liste Firefox auswählen und einen Haken machen bei "immer
mit diesem Programm öffnen.
Dann sollte sowohl das Öffnen gehen als auch die Dateien wieder das
richtige Icon haben.
R/\LF
Hallo Ralf!

Leider nicht, ich tat, wie mir aufgetragen wurde, das Ergebnis ist
dasselbe. Durch die Auswahl des Kontextmenüs "Öffnen mit..." kann ich
eine Standardaktion festlegen. Die stimmt bei mir aber. Das Programm
öffnet doch mit Doppelklick!

Das Einzige, was nicht stimmt ist das zugeordnete Icon. Und das wird,
was ich so in einschlägigen Webseiten gelesen habe, in irgendeinem
Registryschlüssel mit einem sogenannten "IconHandler" verknüpft.

Historie: Das Problem trat erstmals auf, als ich versehentlich den
Microsoft Internet Explorer als Standardwebbrowser in den Einstellungen
unter "Programmzugriff und -standards" festgelegt hatte, danach wieder
den Mozilla Firefox zugeordnet habe und den Zugriff auf den Internet
Explorer deaktiviert habe.

Dein Vorgehen funktioniert, wenn ich das mit dem Internet Explorer
mache, dann wird mir das e-Symbol angezeigt. Ich möchte aber gerne mit
Mozilla öffnen und ein Dateisymbol haben, was sich von dem unbekannten
Datei-Symbol unterscheidet. Von mir aus auch ein Pinkfarbenes Symbol mit
gelben Streifen. ;-)

Das Problem liegt meiner Ansicht nach an Firefox bzw. an einer
Registryeinstellung.

Wer weiss hierzu mehr?!

Grüße
Andreas
Heiko Rost
2006-03-03 12:44:32 UTC
Permalink
Post by Andreas Weller
Was ich schon ausprobiert habe: Im Regedit den IconHandler auf Firefox
umzubiegen, in dem Schlüssel ShellEx. Dort steht bei mir
"C:\..bla...\Firefox.exe,1" - also das zweite Icon mit dem Fuchs und dem
weissen Papier im Hinterfrund.
Im IconHandler darf AFAIK nur eine CLSID (die {...} Hexzahlen) eingetragen
sein. Am besten ist, Du löscht den IconHandler-Schlüssel komplett.
Anschließend benutzt Windows wieder den DefaultIcon-Eintrag, den Du auch im
Arbeitsplatz bei den Ordneroptionen einstellen kannst.

Gruß Heiko
Andreas Weller
2006-03-09 18:19:09 UTC
Permalink
Post by Andreas Weller
Hallo,
ich verzweifle gerade an meiner Mozilla-Firefox Installation unter
Windows: Ich habe ein Problem mit meinen der im Windows Explorer
zugeordneten Icons. Der Explorer zeigt mir für eine HTML-Datei das
Symbol für "Unbekannter Dateityp" an, klicke ich drauf, öffnet sich
Firefox normal. Also kann's ja nur an den Icons liegen, dachte ich.
Schön: Gucke ich unter Windows Explorer, Ordneroptionen, zugeordnete
Wenn ich auf den Dateityp klicke um ihn zu bearbeiten, sehe ich für den
Dateityp (Erweiterung HTML oder HTM) das Symbol des Firefox-Browsers,
das ich auch gerne im Explorer angezeigt bekommen hätte, im Explorer
jedoch wird mir das Dateisymbol für unbekannte Dateien angezeigt, ganz
egal welches Icon ich auswähle.
Welche Zuordnung ist hier verloren gegangen? Ich möchte die Erweiterung
nicht unbedingt löschen, Da mit die ganzen Aktionen (Edit, Print, Open)
kaputt gehen.
Was ich schon ausprobiert habe: Im Regedit den IconHandler auf Firefox
umzubiegen, in dem Schlüssel ShellEx. Dort steht bei mir
"C:\..bla...\Firefox.exe,1" - also das zweite Icon mit dem Fuchs und dem
weissen Papier im Hinterfrund. Den IconCache von Windows habe ich auch
schon erhöht.
Was ist bei mir falsch? Weiss jemand genau, welche Einstellungen richtig
sind?
Ich verwende Mozilla Firefox 1.5.0.1, Windoof XP Home (5.1, Build 2600)
mit aktuellen Patches (SP2...), der eingebaute Internet Explorer ist
6.0.2900.2180
Vielen Dank für Eure Hilfe!
Grüße
Andreas
Wollte mich nochmal melden... Ich habe das Problem immer noch, kann denn
wirklich keiner helfen? Ich habe echt keine Lust, das Firefox-Ding
nochmal neu zu installieren, falls das überhaupt helfen würde.

Es kann doch nicht so schwer sein, ein Icon für 'ne Dateiendung
festzulegen? Wo kann ich denn was hierüber rausfinden?

Grüße
Andreas
Heiko Rost
2006-03-09 18:40:23 UTC
Permalink
Post by Andreas Weller
Wollte mich nochmal melden... Ich habe das Problem immer noch, kann denn
wirklich keiner helfen?
Hat mein Vorschlag vom 3.3., den IconHandler-Schlüssel komplett zu löschen,
nicht geholfen?
Post by Andreas Weller
Ich habe echt keine Lust, das Firefox-Ding
nochmal neu zu installieren, falls das überhaupt helfen würde.
Das wäre wahrscheinlich nutzlos.
Post by Andreas Weller
Es kann doch nicht so schwer sein, ein Icon für 'ne Dateiendung
festzulegen? Wo kann ich denn was hierüber rausfinden?
Sobald ein IconHandler ins Spiel kommt, ist es schwierig. Wenn Du dann ein
eigenes Icon festlegen willst, hilft meiner Erfahrung nach nur Löschen des
Schlüssels über den Registry-Editor.

Gruß Heiko
Andreas Weller
2006-03-09 18:53:39 UTC
Permalink
Post by Heiko Rost
Post by Andreas Weller
Wollte mich nochmal melden... Ich habe das Problem immer noch, kann denn
wirklich keiner helfen?
Hat mein Vorschlag vom 3.3., den IconHandler-Schlüssel komplett zu löschen,
nicht geholfen?
Nein, leider nicht.
Post by Heiko Rost
Post by Andreas Weller
Ich habe echt keine Lust, das Firefox-Ding
nochmal neu zu installieren, falls das überhaupt helfen würde.
Das wäre wahrscheinlich nutzlos.
Post by Andreas Weller
Es kann doch nicht so schwer sein, ein Icon für 'ne Dateiendung
festzulegen? Wo kann ich denn was hierüber rausfinden?
Sobald ein IconHandler ins Spiel kommt, ist es schwierig. Wenn Du dann ein
eigenes Icon festlegen willst, hilft meiner Erfahrung nach nur Löschen des
Schlüssels über den Registry-Editor.
Gruß Heiko
Heiko Rost
2006-03-09 20:58:26 UTC
Permalink
Post by Andreas Weller
Post by Heiko Rost
Hat mein Vorschlag vom 3.3., den IconHandler-Schlüssel komplett zu löschen,
nicht geholfen?
Nein, leider nicht.
Hast Du auch wirklich den /Schlüssel/ gelöscht, also im linken Fenster von
regedit mit der rechten Maustaste auf den Text "IconHandler" geklickt und
"Löschen" ausgewählt? Wenn Du nur im rechten Fenster die unter "Standard"
eingetragene Zeichenkette löscht, hilft das nicht.

Gruß Heiko
Andreas Weller
2006-03-14 19:04:43 UTC
Permalink
Post by Heiko Rost
Post by Andreas Weller
Post by Heiko Rost
Hat mein Vorschlag vom 3.3., den IconHandler-Schlüssel komplett zu löschen,
nicht geholfen?
Nein, leider nicht.
Hast Du auch wirklich den /Schlüssel/ gelöscht, also im linken Fenster von
regedit mit der rechten Maustaste auf den Text "IconHandler" geklickt und
"Löschen" ausgewählt? Wenn Du nur im rechten Fenster die unter "Standard"
eingetragene Zeichenkette löscht, hilft das nicht.
Gruß Heiko
Der REG-Schlüssel sieht bei mir so aus:

Arbeitsplatz\HKEY_CLASSES_ROOT\htmlfile-----+
|
+--BrowseInPlace
|
+--ScriptHostEncode
|
+--Shell----+
| +Edit
| +Open
| +Opennew
| +print
| +printto
+--ShellEx
Heiko Rost
2006-03-14 19:51:00 UTC
Permalink
...
In der Liste sollte noch der Eintrag

\HKEY_CLASSES_ROOT\htmlfile\DefaultIcon

vorhanden sein. Den benutzt Windows, um bei den Ordneroptionen das Symbol
auszuwählen.

Das eigentlich interessante ist unter

\HKEY_CLASSES_ROOT\htmlfile\ShellEx

zu finden. Dort sollte auch der IconHandler stehen, der das Problem
verursacht.

Und um sicher zu gehen, was wird bei den Schlüsseln

\HKEY_CLASSES_ROOT\.htm
\HKEY_CLASSES_ROOT\.html

rechts als Standard angezeigt? Bei mir hat die Suite da jeweils MozillaHTML
eingetragen, möglicherweise benutzt FireFox auch einen anderen Eintrag.
Wenn ja, wäre das Bearbeiten von \HKCR\htmlfile natürlich nutzlos.

Gruß Heiko
Andreas Weller
2006-03-18 11:05:12 UTC
Permalink
Hallo,

erstmal vielen Dank für eure Bemühungen, obwohl das Problem immer noch
nicht gelöst ist. Bei der Sache habe ich aber so Einiges in der
Registrierung gelernt, so dass es durchaus einen Erfolg hat. :-)
Post by Heiko Rost
...
In der Liste sollte noch der Eintrag
\HKEY_CLASSES_ROOT\htmlfile\DefaultIcon
vorhanden sein. Den benutzt Windows, um bei den Ordneroptionen das Symbol
auszuwählen.
Der Schlüssel exisitierte bei mir nicht. Ich habe daraufhin versucht,
den Unterschlüssel anzulegen mit dem Wert "C:\Programme\Mozilla
Firefox\firefox.exe,1". Als ich das tat, passierte gar nix. Also wieder
weggemacht.
Post by Heiko Rost
Das eigentlich interessante ist unter
\HKEY_CLASSES_ROOT\htmlfile\ShellEx
Da steht bei mir drin: "C:\PROGRA~1\MOZILL~1\FIREFOX.EXE,1" - das hatte
ich schonmal per Hand geändert auf "C:\Programme\Mozilla
Firefox\firefox.exe,1", ist aber vermutlich durch das hin- und
herswitchen bei Explorer mit "Öffnen mit..." zwischen Internetexplorer
und Mozilla wieder geändert worden.

Wenn ich den Internetexplorer als Öffnen mit... eintrage, ändert sich
das Symbol auf ein weisses Blatt Papier mit dem berühmten
Windowsexplorer e, stelle ich es wieder zurück, habe ich wieder das
Symbol für unbekannte Objekte.
Post by Heiko Rost
zu finden. Dort sollte auch der IconHandler stehen, der das Problem
verursacht.
Und um sicher zu gehen, was wird bei den Schlüsseln
\HKEY_CLASSES_ROOT\.htm
\HKEY_CLASSES_ROOT\.html
rechts als Standard angezeigt? Bei mir hat die Suite da jeweils MozillaHTML
eingetragen, möglicherweise benutzt FireFox auch einen anderen Eintrag.
Wenn ja, wäre das Bearbeiten von \HKCR\htmlfile natürlich nutzlos.
Da steht schon das "htmlfile" drin. Habe das mal auf MozillaHTML
geändert und versucht, das brachte aber keinen Erfolg.
Post by Heiko Rost
Gruß Heiko
Re
Andreas
Heiko Rost
2006-03-18 12:40:51 UTC
Permalink
Post by Andreas Weller
Der Schlüssel exisitierte bei mir nicht. Ich habe daraufhin versucht,
den Unterschlüssel anzulegen mit dem Wert "C:\Programme\Mozilla
Firefox\firefox.exe,1". Als ich das tat, passierte gar nix. Also wieder
weggemacht.
Der Eintrag hat keine Auswirkung, solange der IconHandler noch da ist.
Außerdem wirkt sich die manuelle Änderung in der Registry nicht sofort auf
die Anzeige im Explorer aus.
Post by Andreas Weller
Post by Heiko Rost
Das eigentlich interessante ist unter
\HKEY_CLASSES_ROOT\htmlfile\ShellEx
Da steht bei mir drin: "C:\PROGRA~1\MOZILL~1\FIREFOX.EXE,1" - das hatte
ich schonmal per Hand geändert auf "C:\Programme\Mozilla
Firefox\firefox.exe,1",
Das hat an *dieser* Stelle nichts zu suchen, als Eintrag für DefaultIcon
wäre er in Ordnung. Unter ShellEx werden keine Dateinamen benutzt, sondern
Schlüssel in der Form "{F1B9284F-E9DC-4e68-9D7E-42362A59F0FD}" (der ist
natürlich nur ein Beispiel und hat mit Deinem Problem nichts zu tun).
Post by Andreas Weller
ist aber vermutlich durch das hin- und
herswitchen bei Explorer mit "Öffnen mit..." zwischen Internetexplorer
und Mozilla wieder geändert worden.
Moment, nicht daß es hier Mißverständnisse gibt. Unter
\HKEY_CLASSES_ROOT\htmlfile\ShellEx sollte es im linken Fenster von regedit
eine Baumstruktur wie

\HKEY_CLASSES_ROOT\htmlfile\ShellEx
|
+-ContextMenuHandlers
|
+-IconHandler
|
+-PropertySheetHandlers

geben. Bei Dir sieht der Baum vermutlich etwas etwas anders aus, das
Wichtige ist jetzt der Eintrag IconHandler. Diesen klickst Du mit der
linken Maustaste an und wählst löschen. Gibt es den nicht mehr, hast Du ihn
möglicherweise bereits bei Deinen Experimenten gelöscht.

Wenn er gelöscht ist, wählst Du im Arbeitsplatz über "Extras" -
"Ordneroptionen" - "Dateitypen" die Erweiterung "htm" aus. Dann drückst Du
den Knopf "Erweitert" (*1), anschließend "Anderes Symbol". Über
"Durchsuchen" wählst Du die firefox.exe und anschließend das gewünschts
Symbol aus. Das selbe wiederholst Du für die Erweiterung "html". Wenn Dir
jetzt immer noch einm falsches Symbol angezeigt wird, weiß ich auch nicht
weiter.

(*1) Sollte es "Erweitert" nicht geben, mußt Du erst "Wiederherstellen"
drücken.
Post by Andreas Weller
Post by Heiko Rost
Und um sicher zu gehen, was wird bei den Schlüsseln
\HKEY_CLASSES_ROOT\.htm
\HKEY_CLASSES_ROOT\.html
rechts als Standard angezeigt? Bei mir hat die Suite da jeweils MozillaHTML
eingetragen, möglicherweise benutzt FireFox auch einen anderen Eintrag.
Wenn ja, wäre das Bearbeiten von \HKCR\htmlfile natürlich nutzlos.
Da steht schon das "htmlfile" drin. Habe das mal auf MozillaHTML
geändert und versucht, das brachte aber keinen Erfolg.
Du solltest dort nur nachschauen, aber nichts bearbeiten. :-( Die Registry
ist das Gehirn von Windows, wenn Du da einfach irgendetwas änderst, kann
das recht unangenehme Folgen haben.

Gruß Heiko
Andreas Weller
2006-03-19 16:01:22 UTC
Permalink
Post by Heiko Rost
Du solltest dort nur nachschauen, aber nichts bearbeiten. :-( Die Registry
ist das Gehirn von Windows, wenn Du da einfach irgendetwas änderst, kann
das recht unangenehme Folgen haben.
Gruß Heiko
Hallo again,

schon klar, dass man da nicht unbedingt fummeln sollte, deswegen gibt es
ja die ganzen Tweak-Dinger. Ich habe das Problem jetzt aber auf einem
ganz anderen Weg in den Griff bekommen:

Es gibt ein Visual Basic Script, dass den Code an die richtigen Stellen
setzt! Beim Stöbern bin ich auf diese Seite gekommen:

http://windowsxp.mvps.org/htmicon.htm

Jetzt habe ich zwar das Firefox-Icon nicht, aber wenigstens auch nicht
mehr das Unbekannt-Symbol, sondern der ganz normale Interneticon vom
Explorer. Das reicht mir ja auch schon. Ich habe keinen Bock mehr auf
irgendwelche Icons! :-)

Trotzdem Danke für alle Bemühungen!

Grüße
Andreas
Andreas Weller
2006-03-19 16:04:20 UTC
Permalink
Post by Andreas Weller
Jetzt habe ich zwar das Firefox-Icon nicht, aber wenigstens auch nicht
mehr das Unbekannt-Symbol, sondern der ganz normale Interneticon vom
Explorer. Das reicht mir ja auch schon. Ich habe keinen Bock mehr auf
irgendwelche Icons! :-)
Nach dem Rebuilden des Icon-Caches läuft das jetzt auch. Endlich habe
ich mein Füchschen wieder. *gg* :-)
Post by Andreas Weller
Trotzdem Danke für alle Bemühungen!
Grüße
Andreas
Ralf Eichler
2006-03-09 20:12:40 UTC
Permalink
Post by Heiko Rost
Post by Andreas Weller
Es kann doch nicht so schwer sein, ein Icon für 'ne Dateiendung
festzulegen? Wo kann ich denn was hierüber rausfinden?
Sobald ein IconHandler ins Spiel kommt, ist es schwierig. Wenn Du dann ein
eigenes Icon festlegen willst, hilft meiner Erfahrung nach nur Löschen des
Schlüssels über den Registry-Editor.
Ich denke der OP will _nicht nur_ ein passendes Icon, sondern auch dass
sich bei Doppelklick dann auch das entsprechende Programm öffnet, oder?

R/\LF
Heiko Rost
2006-03-09 20:47:41 UTC
Permalink
Post by Ralf Eichler
Ich denke der OP will _nicht nur_ ein passendes Icon, sondern auch dass
sich bei Doppelklick dann auch das entsprechende Programm öffnet, oder?
In seinem ersten Posting schreibt er, daß der Firefox beim Doppelklick auf
eine HTML-Datei ganz normal startet, deshalb besteht dieses Problem nicht.
Ihm fehlt nur das passende Icon, und wegen des von irgendeinem anderen
Programm installiertem IconHandler läßt sich das nicht mehr im Arbeitsplatz
über die Ordneroptionen ändern.

Gruß Heiko
Ralf Eichler
2006-03-09 21:15:21 UTC
Permalink
Post by Heiko Rost
In seinem ersten Posting schreibt er, daß der Firefox beim Doppelklick auf
eine HTML-Datei ganz normal startet, deshalb besteht dieses Problem nicht.
Ihm fehlt nur das passende Icon, und wegen des von irgendeinem anderen
Programm installiertem IconHandler läßt sich das nicht mehr im Arbeitsplatz
über die Ordneroptionen ändern.
Ok. Das hatte ich überlesen.

R/\LF
Manfred Drasch
2006-03-14 18:49:29 UTC
Permalink
Hallo,

wie sieht es bei dir mit dem folgenden Eintrag aus?

[HKEY_CLASSES_ROOT\FirefoxHTML\DefaultIcon]
@="C:\\Programme\\Mozilla Firefox\\Firefox.exe,1"


Hast Du schon "TweakUI" von den "Powertoys for Windows XP" getestet?
Dort Repair Icons wählen.

Gruß Manfred
Andreas Weller
2006-03-18 10:47:20 UTC
Permalink
Post by Andreas Weller
Hallo,
wie sieht es bei dir mit dem folgenden Eintrag aus?
[HKEY_CLASSES_ROOT\FirefoxHTML\DefaultIcon]
@="C:\\Programme\\Mozilla Firefox\\Firefox.exe,1"
Da stand "%1" drin. Warum auch immer, habe jetzt das angegebene
eingetragen, leider ohne Erfolg.
Post by Andreas Weller
Hast Du schon "TweakUI" von den "Powertoys for Windows XP" getestet?
Dort Repair Icons wählen.
Wusste zwar nicht, dass es für XP auch ein UserInterface Tweaker gibt,
aber die Lösung verschaffte mir auch das nicht.
Post by Andreas Weller
Gruß Manfred
Grüße
Andreas
Lesen Sie weiter auf narkive:
Loading...